Child pages
  • Ansible'ın çalışacağı sunucunun kurulması
Skip to end of metadata
Go to start of metadata

 

Ansible'ın çalışacağı server kurulumu icin ansible roller yaratılmıştır.

Çalışma Ubuntu 14.04 ve Ubuntu 16.04 sürümleri üzerinde yapılmıştır Ubuntu 16.04 üzerinde sorunsuz çalışmaktadır.

Bu döküman yayınlandığında son ansible sürümü 2.4.2 ve desteklediği minimum python sürümü 3.5 tir. Ubuntu 16.04 python 3.5 ile gelmektedir.

 

Eklenen Roller

  • add_new_user.yaml(Playbook)
  • plusclouds.harden-ubuntu
  • plusclouds.ansible-server


Öncelikle ilgili serverda "add_new_user.yaml" playbooku çalıştırılarak kullanılacak user ve userin root yetkisi eklenmelidir.

Ardından ayarlanan user ve passwordu kullanarak aşağıdaki playbook çalıştırılmalıdır.

 

Ansible'ın çalışacağı server kurulumu yine ansible kullanılarak yapılabildiği için api tarafından belirlenen herhangi bir ansible sunucusu ile yeni ansible sunucular yaratılabilir durumdadır.

  • No labels